60 AutoCAD Tips in 60 Minutes

Lynn Allen
Autodesk

Learning Objectives

Learning Objective 1: Learn how to complete AutoCAD tasks in fewer steps
Learning Objective 2: Learn how to use the new features from recent releases of AutoCAD software
Learning Objective 3: Discover tips that AutoCAD software veterans and gurus know
Learning Objective 4: Learn how to become more productive with AutoCAD

Description

If you want a plethora of power-user tips, then be sure to join Cadalyst columnist and Autodesk Technical Evangelist Lynn Allen as she takes you through a whirlwind of productivity techniques that are certain to improve your everyday drawing life. At a tip a minute, you’ll be sure to discover some top secret AutoCAD features that will remove tedium and boost your ability to meet project deadlines. As usual—Lynn will be providing a whole new batch of tips (for those of you who have attended before!)

Speaker(s)

Lynn Allen, Cadalyst columnist and Autodesk Technical Evangelist, speaks to more than 20,000 users worldwide each year. For the past 25 years she has written a column for Cadalyst magazine called "Circles and Lines" and is the voice behind the popular Cadalyst videos –“Tips and Tricks with Lynn Allen”. Lynn started using Autodesk® software over 25 years ago, and taught at the corporate and collegiate level for 13 years before joining Autodesk. A sought-after public speaker with a unique comedic style, Lynn is always one of the highest rated presenters at Autodesk University where she has had the most popular class for over ten years. Active in social media with 21,000 Twitter followers, she is also the author of three AutoCAD books, her latest entitled AutoCAD Professional Tips and Techniques.

Note: Tips that are specific to AutoCAD 2018 are indicated with
Quick Access Toolbar
The Quick Access Toolbar is easy to get to at any time. Be sure to customize it with your frequently used commands for maximum productivity!

1) Add the Layer drop-down added to QA toolbar
Are you tired of returning to the home tab on the ribbon to change layers? Put the Layer drop-down on the Quick Access toolbar! In AutoCAD 2018 you can easily add the Layer drop-down list to the QA toolbar from the down-arrow.

2) Customize the QA Toolbar via the ribbon
Right click on any tool in the ribbon and select “Add to Quick Access Toolbar” to add any tool to the QA toolbar for easy access.

3) Customize the QA Toolbar via the Quick CUI
You can also grab commands from the QUICKCUI and add them to the QA Toolbar. Simply select “more commands” from the drop-down list on the QA Toolbar to access QCUI. Grab the command and drop it into place.

4) Move the QA Toolbar under the ribbon for the maximum number of tools
You’ll find this option in the QA Toolbar drop-down list.

5) Show Menu Bar
I know some of you miss the old pull-down menus…well you can bring them back by selecting “Show Menu Bar” from the QA toolbar drop-down menu. I’m not condoning it – I’m just showing you how to do it! (embrace the ribbon People!)
**User Interface Tips:**
*If you don’t know your way around the UI – you’re missing out on some valuable productivity. Let’s take a look at some old and new features that should put you on the road to AutoCAD happiness…*

6) **File navigation dialog boxes remember your column sort order preference**
   In AutoCAD 2018 you’ll find that whenever you modify the column sort order in commands that ask for file selections, AutoCAD will remember the sort order! What a pleasant addition after all these years.

7) **Autocomplete in Insert**
   Tired of scrolling through lists of blocks? Now you only need to type in a couple of characters and AutoCAD will quickly find your block of choice thanks to AutoComplete! (Hey – if nobody tells you about it – how will you know?)

8) **Easy to “Find” commands from Help**
   Do you ever get frustrated trying to find commands in the ribbon? The HELP menu has some cool “Find” tools to help you out! (now you can stop hitting your head against the wall!). Simply click on the “Find” button in the correlated help command and AutoCAD will show you exactly where that pesky command is hiding! (You’re welcome!)

9) **Find commands from the Application Menu**
   You can also find where commands are located in the ribbon from the Application Menu.

10) **Set the number of recently used files to 50**
    Oh boy – the default for the number of recently used files is still 9! That’s dreadful. Be sure to change this number to 50 in the **Options=> Open and Save** tab for maximum flexibility. You’ll end up searching much less for your drawing files! This also affects your Start tab.
11) Set up the Status Bar for maximum productivity with the “Hamburger”
Do you have tools on the Status Bar that you aren’t using? Get rid of them! Click on the “hamburger” in the lower right corner of the drawing editor to turn the various tools on/off.

12) Dock layout tabs inline with the Status Bar
Are you greedy with your screen real estate? Me too! Be sure the layout tabs aren’t taking up any more room than they need to by right clicking on any layout tab to “Dock Inline with Status Bar”. (Is “inline” even a word?)

13) Dock frequently used palettes
I always have a few of my fav palettes docked on the left side of my screen for speedy access (Sheetset Manager, Layer Manager and Properties). Simply right-click on the palette side bar to allow docking, dock to the left and then opt for icons or text (whichever you prefer). I’m an Icon girl myself! I am also a big fan of “Auto-hide”

14) Tear off frequently used panels
If you find yourself using a specific panel of the ribbon for a while (like dimensioning) – why not tear it off and leave it on the screen so it’s handy? Just grab it and drag it off of the ribbon to your preferred place on the screen. Click on the tool in the upper right corner to return the panel to the ribbon.

15) Control the color of the rubber-band line
Ok…so somebody must have asked for it because it’s been added to AutoCAD 2018! Now you can change the color of the rubber-band line to suit your mood of the day. Options=>Display=>Colors
16) **Selected objects stay in the selection set – even if you pan or zoom off screen (SELECTIONOFFSCREEN)**

This is a great new feature in AutoCAD 2018! Now you can pan and zoom while selecting objects and maintain your selection set. Finally! If for some reason you aren’t keen on this new feature – you can turn SELECTIONOFFSCREEN to 0.

17) **CLOSEALLOTHE command**

If you’ve ever wanted to close all of your drawings except for the current one – then use this handy command (don’t worry – you’ll have a chance to save them first). You can also find this command in the right-click menu of the filetabs.

**SYSVARMONITOR**

The System Variable Monitor is a top secret AutoCAD command to help you keep your favorite system variables set to your desired settings. It will happily alert you when they are changed and make it easy for you to reset them back to their desired states.

18) **Save your desired System Variable settings**

You will need to execute the SYSVARMONITOR command from the command prompt since you won’t find it in the ribbon (I told you it was top secret). Here you will find it easy to add your favorite system variables to the existing list with the Edit List option. The SYSVARMONITOR comes prepopulated with some basic system variables the Autodesk Product Support team felt were important (and were tired of taking calls about). : )
19) **Set a Notification to warn of changes**
You can enable a balloon notification, a message at the command line and a tool on the Status Bar to display (AutoCAD 2018) should any of your preferred settings become changed.

20) **New Sysvarmonitor tool on Status Bar**
In AutoCAD 2018, a new SYSVARMONITOR tool appears on the status bar whenever a system variable has been changed.

21) **Reset All to return to desired settings**
It's easy to reset the system variables to their desired settings from the status bar (right click on the System Variable Monitor tool (AutoCAD 2018) or from the SYSVARMONITOR command.

---

**A Few Handy CUI Tips**

22) **Float your favorite tools to the top of the Ribbon panels**
If your favorite tool isn't the one that displays by default on the ribbon panels, you can float it to the top of the pile. Execute the CUI command, select Ribbon, Tabs and then find the tab and panel of your choice. Click on the tool you want to modify.

Float your fav tool to the top by dragging it up so it falls right below “Primary Command”. In the image to the right, 3-point circles will now display as the default option for drawing a Circle on the ribbon.

23) **Customize shortcut keys**
If you're handy with the keyboard, you can add a few of your own keyboard shortcuts to speed up your drawing life (or make changes to the existing keyboard shortcuts.
Expand Keyboard Shortcuts in the CUI and expand Shortcut Keys. Select a command from
24) Customize the Roll-over tool tips
Roll-over tips appear whenever you move your cursor over an object. By default they provide very limited property information. You can tell AutoCAD, through the CUI, to display additional valuable information, such as area or length of a closed polyline. Select Rollover Tooltips, go to the object of your choice and select the properties you wish to display.

25) Double-click actions
Commands are executed when you double-click on objects in AutoCAD. You have complete control over the corresponding commands in the CUI. Many of them default to Quick Properties – I bet you can come up with a better option! Simply drag and drop your preferred command to the corresponding object.
26) Button Menus
We rarely take full advantage of the buttons on our mouse and yet they are so easily accessible! There are four (yes four!) menus you can assign commands to for your mouse! The pick button (button 1) is not configurable but the other buttons are! Same deal as before – simply drag and drop your fav command into place.

27) Button Menus – Shift+Click
- Shift+Click
  - Button 2: Layer Properties
  - Button 3: Transparent Orbit

28) Button Menus - Ctrl + Click
- Ctrl+Click
  - Button 2: Snap Menu
  - Button 3: Transparent Swivel

29) Button Menus – Shift + Ctrl+Click!
Only for the VERY coordinated!
- Ctrl+Shift+Click
  - Button 2: Snap Menu
  - Button 3: Transparent Orbit

XREF Tips! (Courtesy of AutoCAD 2018)
We all have a love/hate relationship with XREFs…we love them when they work – we hate them when those pesky links get broken! AutoCAD 2018 has made great strides when it comes to XREFs both in helping avoid those broken links to begin with and helping you easily fix them when needed. Think of all the money you’ll save on therapy!

30) Now XREFS default to relative, reducing broken paths.
When attaching an XREF, you’ll find that the default path type is now relative (as opposed to
31) Easily fix multiple broken paths for externally referenced files
Now when you select a new path for an XREF with a broken link, AutoCAD will kindly ask you if you’d like it to apply the same path to other references with broken links that might reside in the same directory! This alone is going to save you lots of time!

32) Assign a relative path to an unnamed host drawing
In the past, if you tried to make an attached XREF relative before saving the host drawing – AutoCAD would have nothing to do with it! The more chill AutoCAD 2018 will let you though – while waiting patiently for you to assign a name to the host drawing at your convenience.

33) New Find and Replace option fixes many broken links at once
A new handy “Find and Replace” option in the right click menu (in the XREF manager) should also help you fix many of those pesky broken links at one time!

34) Unreferenced (now Orphaned) Xrefs display properly in TreeView
Those poor orphaned Xrefs who can’t find their parents! How can you help them when the parent drawing doesn’t display in the TreeView? AutoCAD 2018 kindly shows you the parent drawing so you can fix the problem (and put the family back together!)

35) SAVEAS can save links and change references to Relative
So often when we save drawings with Xrefs to a different directory – we end up with broken links. That’s because some of the references were not set to Relative. AutoCAD 2018 has a built in protection to help us save ourselves from this dreaded fate!
36) **AutoCAD 2018 can open unloaded references**
Opening an unloaded Xref in the past was a big No-No...AutoCAD would insist on making you load the Xref first before opening. Don’t you hate all these tedious extra steps? AutoCAD 2018 to the rescue!

37) **References renamed outside of XREF manager automatically updated**
If you have ever renamed a reference outside of the External References Manager – then you know Xref Manager takes its own sweet time updating the name. You won’t have to perform any extra tricks to get the Xref Manager to update – it all magically happens for you in AutoCAD 2018!

**Object Selection Tips**
*Statistics say we spend more time editing objects than actual drawing in AutoCAD – so here are some tips for selecting objects to help you save some time along the way!*

38) **Add Selected Object**
When you need to add another object with all the same properties as an existing one – take the lazy route and use the right-click menu and pick “Add Selected Object”. This will create the same type of object, with all the same properties without changing the current layer, linetype etc. Perfect for the lazy AutoCAD User like me! Also perfect when working on other people’s drawings where you have no idea what their settings were...

39) **Duplicate Dimensions and Text**
No need to go on a reconnaissance mission to determine the style, overrides, height, etc of dimensions or text. Simply click on an existing dimension or text string to easily add another similar object with the same style, overrides, etc.

40) **Select Similar**
When you need to select objects of the same type, layer, color, etc. – then Select Similar is your friend! Found in the right click menu, simply click on an object and AutoCAD will find all the other objects in the drawing that match up with the selected object.
41) Select Similar Settings
You have complete control over which settings are matched with Select Similar. Execute the Selectsimilar command from the command prompt and choose the Settings option to make your selection (btw-Name should be “Type”!)

![Select Similar Settings](image1.jpg)

42) Selection Cycling
In tight drawings, selection cycling can come in handy for selecting closely spaced objects. It also comes in handy when selecting objects which are on top of each other like hatch patterns and their boundaries. Use the tool on the status bar to toggle Selection Cycling On/Off or Ctrl+W.

![Selection Cycling](image2.jpg)

**Timesavers**

43) Use CHANGE command to quickly lengthen/shorten lines
An oldie but a goodie…Select the objects you want to change, then select the point you want to lengthen or shorten the lines to. Make sure your ortho is on!

44) Ctrl to Reverse an Arc
Still think that arcs only want to go counter-clockwise? Think again! Use the Control key to reverse the direction of arcs.

45) Oops
Use OOPS to bring back the last group of objects erased regardless of how many steps you’ve done since the ERASE command (much better than undoing all your work!)

46) Undo Mark
Set a marker in AutoCAD for those times you feel like experimenting so you can easily undo “Back” to that mark.

47) Undo Back
Stop hitting U a zillion times to go back to the beginning of your drawing! Undo Back will do
the trick. If you’ve set a Marker, Undo Back will only go back to the Marker.

48) Ctrl+R to Cycle Viewports
Don’t you hate it when you can’t get inside a viewport that is within another viewport? Use Ctrl+R to cycle through your viewports to get to it!

Cool System Variables

49) PEDITACCEPT
Are you tired of answering the age-old question in the PEDIT command of “Object selected is not a polyline, do you want to turn it into one?” Me too! That’s why I have set PEDITACCEPT to 1! You’ll never have to answer that question again.

50) TRAYNOTIFY
Do you like those friendly bubbles that pop up with useful information from the system tray? If you prefer to remain in the dark – turn them off with TRAYNOTIFY.

51) MTJIGSTRING
Let’s face it – the sample string for text in AutoCAD is so boring (abc)...Snore! I love customizing the sample string in suit my mood. Use MTJIGSTRING to customize your sample text string (up to 10 characters)

52) Friendly way to work with system variables...SYSVDLG
The Express Tool SYSVDLG is a friendly way to work with system variables. It shows you the default settings for each system variable, whether the variable is saved in the registry or not, along with other valuable information. Hint: use wildcards to find specific variables

53) Save your system variables to a file
Use SYSVDLG to save your valued system variable settings to a file (.SVF file). Then if things go wrong (and let’s face it – that happens all the time) you can easily return your
system variables to your favorite settings with “Read…”!

**Clean Up Your Drawings!**
*Come on people! Your drawings are drowning with duplicate objects, extra vertices, and inaccurate dimensions. Tidy them up with some handy clean-up commands!*

54) **BLEND command to complete curves**
This little-known command is great for completing curves without the nightmare tangential needs of PEDIT. You’ll find it hiding under the FILLET command on the Home tab of the ribbon.

55) **JOIN to combine objects into a single polyline**
Extra objects means a larger database and ultimately a slower drawing. Speed your drawings up by joining as many objects together as you can with the Join command! It only takes a few seconds.

56) **Delete Duplicate Objects with OVERKILL**
This handy command (formerly an Express Tool) is a great way to rid your drawing of duplicate objects, extra vertices, etc.

57) **Fix overridden dimensions with DIMREASSOC**
Don’t you hate it when CAD users override dimension values? There’s no way to tell just by looking at a drawing if the dimensions are accurate or not (and the consequences of wrong dimension values can be dire!). Use DIMREASSOC to find those pesky overridden dimensions and then return them to their true value. Then you can go have a little chat with the badly behaved CAD user! Note: Don’t confuse this command with DIMREASSOCIATE – which is a completely different command!
**Ways to Torture your Coworker**

Ok…so you didn’t hear any of these from me…and I’m not REALLY suggesting you should torture your coworker (unless they are a bully of course…because this would be just like the revenge of the nerds). But sometimes it’s fun to play a little joke on your CAD buddies…(I will deny everything!)

58) **Assign “Erase” to the Double Click Actions**
   Earlier I showed you how to customize the double click actions in the CUI. Have fun with your coworkers and assign “Erase” to one or more of the more popular ones (Text, Hatch, etc.) Your coworker will double click on them and they will disappear! Ha-Ha!

59) **Switch Copy and Paste**
   Earlier I also showed you how to customize the shortcut keys. Torture your coworkers by switching Copy and Paste!

60) **CursorType to 1**
   Change the AutoCAD cursor to the Windows cursor! Yikes!

61) **ZoomWheel to 1**
   Reverse the Zoom direction by setting ZOOMWHEEL to 1.

62) **ZoomFactor to 3**
   ZOOMFACTOR controls the speed by which you zoom in and out of your drawing with your mouse. Slowwwwwwwww it all down by setting ZOOMFACTOR to 3.

63) **Turn FILEDIA to 0**
   Who needs a friendly dialog box for selecting files whenever you are prompted to select a file? I do! You do! But maybe your coworker doesn’t… ;)

64) **ModeMacro**
   Put a subliminal message on the Status Bar for your coworker and watch as he tries to figure out how to get rid of it!

65) **UNDEFINE**
   This is a fan favorite! Undefine one or more AutoCAD commands with this powerful command. Have fun with this in the CUI! Use the Redefine command to put the commands back (or leave AutoCAD and come back in…). This is a truly devilish way to torture your coworkers!

66) **Alert**
   You don’t need to know AutoLISP to play a little trick on your coworkers. Here is the syntax you key in at the command line (or in a menu item…get creative!)

   (Alert “Formatting the hard drive…Please wait”)
There you have it! 60 Tips in 60 Minutes. Please feel free to email me with any questions: lynn.allen@autodesk.com or follow me on Twitter for extra tips @Lynn_Allen

Watch my videos on the Cadalyst website: www.cadalyst.com

Download my latest AutoCAD Tips and Tricks booklet at www.autodesk.com/autocadtips